VS:DeleteAllComponents: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (shorten "object" (reserved word))
Line 10: Line 10:
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION DeleteAllComponents(object:HANDLE) : BOOLEAN;
FUNCTION DeleteAllComponents(obj:HANDLE) : BOOLEAN;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.DeleteAllComponents(object):
def vs.DeleteAllComponents(obj):
     return BOOLEAN
     return BOOLEAN
</funcDef>
</funcDef>
Line 22: Line 22:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
object
obj
HANDLE
HANDLE
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.
Line 40: Line 40:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks12.5
Availability: from VectorWorks 12.5


</version>
</version>

Revision as of 06:01, 3 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Deletes all components in an object.

FUNCTION DeleteAllComponents(
obj :HANDLE) : BOOLEAN;
def vs.DeleteAllComponents(obj):
    return BOOLEAN

Parameters

obj HANDLE The object. Can be a wall, round wall, Wall Style, or the Wall Preferences.

Version

Availability: from VectorWorks 12.5