VS:DelChoice

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure DelChoice deletes an item from a VectorScript dialog choice item list.

PROCEDURE DelChoice(
item :INTEGER;
whichChoice :INTEGER);
def vs.DelChoice(item, whichChoice):
    return None

Parameters

item INTEGER Item ID of dialog control.
whichChoice INTEGER Position in list of item to be deleted.

Remarks

Note: deprecated from VW 15+, use RemoveChoice

Delete an item from a combo box

Example

VectorScript

numOptions:=NumChoices(8);
DelChoice(8,(numChoices-1));

Python

numOptions = vs.NumChoices(8)
vs.DelChoice(8,(numChoices-1))

Version

Availability: from VectorWorks 8.0. Deprecated from VW 15+.