VS:DefineCustomObj

From Vectorworks Developer
Revision as of 14:29, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates or edits the format for the specified parametric object.

kCustomObjectPrefNever  = 0
kCustomObjectPrefAlways = 1
kCustomObjectPrefNew    = 2
  • kCustomObjectPrefNever -- Creates the format if it doesn't exist. Does nothing if the format exist. No UI is shown.
  • kCustomObjectPrefAlways -- Creates the format if it doesn't exist. A dialog is show to edit created format or to edit already existing format.
  • kCustomObjectPrefNew -- Creates the format if it doesn't exist. A dialog is shown to edit the format only if it has been just created. If the format existed nothing hapens.
FUNCTION DefineCustomObj(
pluginName  : STRING;
prefWhen  : INTEGER) : HANDLE;
def vs.DefineCustomObj(pluginName, prefWhen):
    return HANDLE

Parameters

pluginName STRING
prefWhen INTEGER

Version

Availability: from All Versions

This is drop-in function.