VS:DefineCustomObj: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(add remark)
(2 intermediate revisions by one other user not shown)
Line 24: Line 24:
pluginName
pluginName
STRING
STRING
 
The name of the plug-in for which preferences to be shown.
</line>
</line>
<line>
<line>
prefWhen
prefWhen
INTEGER
INTEGER
 
When the preference dialog is to be shown. See remarks for details.
</line>
</line>
</lineList>
</lineList>
Line 35: Line 35:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
The parameter '''prefWhen''' can be one of:
* kCustomObjectPrefNever = 0
* kCustomObjectPrefAlways = 1
* kCustomObjectPrefNew = 2
 
([[User:Orso.b.schmid|Orso]], 2016.02.08):
Objects created with this call won't allow you to set a profile group, even if they usually support it.
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 05:31, 8 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Calls GS_DefineCustomObject for a passed plugin name and preference.

FUNCTION DefineCustomObj(
pluginName :STRING;
prefWhen :INTEGER) : HANDLE;
def vs.DefineCustomObj(pluginName, prefWhen):
    return HANDLE

Parameters

pluginName STRING The name of the plug-in for which preferences to be shown.
prefWhen INTEGER When the preference dialog is to be shown. See remarks for details.

Remarks

The parameter prefWhen can be one of:

  • kCustomObjectPrefNever = 0
  • kCustomObjectPrefAlways = 1
  • kCustomObjectPrefNew = 2

(Orso, 2016.02.08): Objects created with this call won't allow you to set a profile group, even if they usually support it.

Version

Availability: from Vectorworks 2014