VS:DefineCustomObj: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(add remark)
(4 intermediate revisions by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Creates or edits the format for the specified parametric object.
Calls GS_DefineCustomObject for a passed plugin name and preference.</desc>
 
<code lang="vs">
kCustomObjectPrefNever  = 0
kCustomObjectPrefAlways = 1
kCustomObjectPrefNew    = 2
</code>
 
*kCustomObjectPrefNever -- Creates the format if it doesn't exist. Does nothing if the format exist. No UI is shown.
*kCustomObjectPrefAlways -- Creates the format if it doesn't exist. A dialog is show to edit created format or to edit already existing format.
*kCustomObjectPrefNew -- Creates the format if it doesn't exist. A dialog is shown to edit the format only if it has been just created. If the format existed nothing hapens.
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION DefineCustomObj(pluginName: STRING; prefWhen: INTEGER) : HANDLE;
FUNCTION DefineCustomObj(pluginName:STRING; prefWhen:INTEGER) : HANDLE;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 35: Line 24:
pluginName
pluginName
STRING
STRING
 
The name of the plug-in for which preferences to be shown.
</line>
</line>
<line>
<line>
prefWhen
prefWhen
INTEGER
INTEGER
 
When the preference dialog is to be shown. See remarks for details.
</line>
</line>
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark>
</return>
The parameter '''prefWhen''' can be one of:
* kCustomObjectPrefNever = 0
* kCustomObjectPrefAlways = 1
* kCustomObjectPrefNew = 2


-----------------------------------------------------------------------------------------------------------
([[User:Orso.b.schmid|Orso]], 2016.02.08):
<remark>
Objects created with this call won't allow you to set a profile group, even if they usually support it.


</remark>
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample></sample>


</sample>
-----------------------------------------------------------------------------------------------------------
<seeAlso></seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Revision as of 05:31, 8 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Calls GS_DefineCustomObject for a passed plugin name and preference.

FUNCTION DefineCustomObj(
pluginName :STRING;
prefWhen :INTEGER) : HANDLE;
def vs.DefineCustomObj(pluginName, prefWhen):
    return HANDLE

Parameters

pluginName STRING The name of the plug-in for which preferences to be shown.
prefWhen INTEGER When the preference dialog is to be shown. See remarks for details.

Remarks

The parameter prefWhen can be one of:

  • kCustomObjectPrefNever = 0
  • kCustomObjectPrefAlways = 1
  • kCustomObjectPrefNew = 2

(Orso, 2016.02.08): Objects created with this call won't allow you to set a profile group, even if they usually support it.

Version

Availability: from Vectorworks 2014