VS:DefineCustomObj: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Creates or edits the format for the specified parametric object.
Calls GS_DefineCustomObject for a passed plugin name and preference.</desc>
 
<code lang="vs">
kCustomObjectPrefNever  = 0
kCustomObjectPrefAlways = 1
kCustomObjectPrefNew    = 2
</code>
 
*kCustomObjectPrefNever -- Creates the format if it doesn't exist. Does nothing if the format exist. No UI is shown.
*kCustomObjectPrefAlways -- Creates the format if it doesn't exist. A dialog is show to edit created format or to edit already existing format.
*kCustomObjectPrefNew -- Creates the format if it doesn't exist. A dialog is shown to edit the format only if it has been just created. If the format existed nothing hapens.
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION DefineCustomObj(pluginName: STRING; prefWhen: INTEGER) : HANDLE;
FUNCTION DefineCustomObj(pluginName:STRING; prefWhen:INTEGER) : HANDLE;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 44: Line 33:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Revision as of 17:36, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Calls GS_DefineCustomObject for a passed plugin name and preference.

FUNCTION DefineCustomObj(
pluginName :STRING;
prefWhen :INTEGER) : HANDLE;
def vs.DefineCustomObj(pluginName, prefWhen):
    return HANDLE

Parameters

pluginName STRING
prefWhen INTEGER

Version

Availability: from Vectorworks 2014