VS:DSH GetDSFieldValue: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:49, 16 September 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets Object's Data Sheet field value, operation status(disabled/enabled/invisible/black/red), value source type (not set/from instance/from mapping).

FUNCTION DSH_GetDSFieldValue(
hObject :HANDLE;
dsName :STRING;
fieldLabel :STRING;
VAR outValue :STRING;
VAR outStatus :INTEGER;
VAR outType :INTEGER) : BOOLEAN;
def vs.DSH_GetDSFieldValue(hObject, dsName, fieldLabel):
    return (BOOLEAN, outValue, outStatus, outType)

Parameters

hObject HANDLE
dsName STRING
fieldLabel STRING
outValue STRING
outStatus INTEGER
outType INTEGER

Version

Availability: from Vectorworks 2020.1