VS:DLDSetLoadDataString: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
(One intermediate revision by the same user not shown)
Line 8: Line 8:
Using selector, sets default load data with string value for the parametric object.
Using selector, sets default load data with string value for the parametric object.
Available selectors : kDLDSelectorGroupName = 2, kDLDSelectorLoadID = 3, kDLDSelectorLoadName = 4, kDLDSelectorPrmLoadID = 6, kDLDSelectorPrmName = 7, kDLDSelectorPrmWeight = 8, kDLDSelPrmTotalDistWght = 9. <br />
Available selectors : kDLDSelectorGroupName = 2, kDLDSelectorLoadID = 3, kDLDSelectorLoadName = 4, kDLDSelectorPrmLoadID = 6, kDLDSelectorPrmName = 7, kDLDSelectorPrmWeight = 8, kDLDSelPrmTotalDistWght = 9. <br />
Selector kDLDSelectorGroupName determinate the category, where the load will be displayed in the overview. This selector can be used with one of the following values: 'Audio', 'Video', 'Light', 'Decoration', 'Cable', 'Truss' and 'LoadingPoint'</desc>
Selector kDLDSelectorGroupName determinate the category, where the load will be displayed in the overview. This selector can be used with one of the following values: 'Audio', 'Video', 'Light', 'Decoration' (displayed as Scenery), 'Cable', 'Truss' and 'LoadingPoint'.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 15:47, 22 May 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Using selector, sets default load data with string value for the parametric object.

Available selectors : kDLDSelectorGroupName = 2, kDLDSelectorLoadID = 3, kDLDSelectorLoadName = 4, kDLDSelectorPrmLoadID = 6, kDLDSelectorPrmName = 7, kDLDSelectorPrmWeight = 8, kDLDSelPrmTotalDistWght = 9.
Selector kDLDSelectorGroupName determinate the category, where the load will be displayed in the overview. This selector can be used with one of the following values: 'Audio', 'Video', 'Light', 'Decoration' (displayed as Scenery), 'Cable', 'Truss' and 'LoadingPoint'.

PROCEDURE DLDSetLoadDataString(
selector :INTEGER;
value :STRING);
def vs.DLDSetLoadDataString(selector, value):
    return None

Parameters

selector INTEGER
value STRING

Version

Availability: from Vectorworks 2018