VS:DBSQLExecuteGet

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves information from the resultSetInstance created with 'DBSQLExecute' or 'DBSQLExecuteDSN'

FUNCTION DBSQLExecuteGet(
resultSetInst :LONGINT;
colIndex :LONGINT;
VAR outColumnName :DYNARRAY[] of CHAR;
VAR outValue :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.DBSQLExecuteGet(resultSetInst, colIndex):
    return (BOOLEAN, outColumnName, outValue)

Parameters

resultSetInst LONGINT
colIndex LONGINT
outColumnName DYNARRAY[] of CHAR
outValue DYNARRAY[] of CHAR

Example

See: VS:DBSQLExecuteDSN

Version

Availability: from Vectorworks 2011