VS:DBObjSQLSetRead

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set an object's SQL query for ODBC read.

This SQL query is used to update the Vectorworks document, so the query should be an SELECT query, e.g.

SELECT [ID],[Center Mark Size],[Use Center Marks],[Height],[Struct Width],[Struct Depth] FROM [Columns] WHERE [ID]=1

FUNCTION DBObjSQLSetRead(
hRecord :HANDLE;
SQLSentence :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.DBObjSQLSetRead(hRecord, SQLSentence):
    return BOOLEAN

Parameters

hRecord HANDLE The handle to linked record.
SQLSentence DYNARRAY[] of CHAR The SELECT query.

Version

Availability: from Vectorworks 2011