VS:DBObjSQLSetRead: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Set an object's SQL sentence for ODBC read.</desc>
Set an object's SQL query for ODBC read.
 
This SQL query is used to update the Vectorworks document, so the query should be an SELECT query, e.g.
 
'''SELECT''' [ID],[Center Mark Size],[Use Center Marks],[Height],[Struct Width],[Struct Depth] '''FROM''' [Columns] '''WHERE''' [ID]=1
 
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 25: Line 31:
hRecord
hRecord
HANDLE
HANDLE
 
The handle to linked record.
</line>
</line>
<line>
<line>
SQLSentence
SQLSentence
DYNARRAY[] of CHAR
DYNARRAY[] of CHAR
 
The SELECT query.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 13:33, 4 November 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set an object's SQL query for ODBC read.

This SQL query is used to update the Vectorworks document, so the query should be an SELECT query, e.g.

SELECT [ID],[Center Mark Size],[Use Center Marks],[Height],[Struct Width],[Struct Depth] FROM [Columns] WHERE [ID]=1

FUNCTION DBObjSQLSetRead(
hRecord :HANDLE;
SQLSentence :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.DBObjSQLSetRead(hRecord, SQLSentence):
    return BOOLEAN

Parameters

hRecord HANDLE The handle to linked record.
SQLSentence DYNARRAY[] of CHAR The SELECT query.

Version

Availability: from Vectorworks 2011