VS:DBDocSetColKey

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set database table column to be as a key.

FUNCTION DBDocSetColKey(
databaseName :DYNARRAY[] of CHAR;
tableName :DYNARRAY[] of CHAR;
columnName :DYNARRAY[] of CHAR;
setIsKey :BOOLEAN) : BOOLEAN;
def vs.DBDocSetColKey(databaseName, tableName, columnName, setIsKey):
    return BOOLEAN

Parameters

databaseName DYNARRAY[] of CHAR Data source name.
tableName DYNARRAY[] of CHAR Table name.
columnName DYNARRAY[] of CHAR Column name.
setIsKey BOOLEAN Set TRUE if this column to be used as key in WHERE clauses.

Version

Availability: from Vectorworks 2011