VS:DBDocGetColumns

From Vectorworks Developer
Revision as of 14:26, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a string representing a ';' delimited lists of the specified table data.

FUNCTION DBDocGetColumns(
database :STRING;
table :STRING;
VAR outNames :DYNARRAY[] of CHAR;
VAR outTypes :DYNARRAY[] of CHAR;
VAR outCanBeKey :DYNARRAY[] of CHAR;
VAR outIsKey :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.DBDocGetColumns(database, table):
    return (BOOLEAN, outNames, outTypes, outCanBeKey, outIsKey)

Parameters

database STRING
table STRING
outNames DYNARRAY[] of CHAR
outTypes DYNARRAY[] of CHAR
outCanBeKey DYNARRAY[] of CHAR
outIsKey DYNARRAY[] of CHAR

Version

Availability: from Vectorworks 2011