VS:DBDocGetColumns: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:26, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a string representing a ';' delimited lists of the specified table data.

FUNCTION DBDocGetColumns(
database :STRING;
table :STRING;
VAR outNames :DYNARRAY[] of CHAR;
VAR outTypes :DYNARRAY[] of CHAR;
VAR outCanBeKey :DYNARRAY[] of CHAR;
VAR outIsKey :DYNARRAY[] of CHAR) : BOOLEAN;
def vs.DBDocGetColumns(database, table):
    return (BOOLEAN, outNames, outTypes, outCanBeKey, outIsKey)

Parameters

database STRING
table STRING
outNames DYNARRAY[] of CHAR
outTypes DYNARRAY[] of CHAR
outCanBeKey DYNARRAY[] of CHAR
outIsKey DYNARRAY[] of CHAR

Version

Availability: from Vectorworks 2011