VS:DBDiagnose: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision: vw2015)
No edit summary
Line 23: Line 23:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample></sample>
<sample>
==== VectorScript ====
<code lang="pas">
PROCEDURE Test;
VAR
isOK : BOOLEAN;
BEGIN
isOK := DBDiagnose;
END;
 
Run(Test);
</code>
 
==== Python ====
<code lang="py">
import vs
def Test():
vs.DBDiagnose()
 
Test()
</code>
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 17:02, 30 September 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Test ODBC connectivity and creates log file in application folder. Returns true if succeeded.

FUNCTION DBDiagnose : BOOLEAN;
def vs.DBDiagnose():
    return BOOLEAN

Example

VectorScript

PROCEDURE Test;
VAR
	isOK : BOOLEAN;
BEGIN
	isOK := DBDiagnose;
END;

Run(Test);

Python

import vs
def Test():
	vs.DBDiagnose()

Test()

Version

Availability: from Vectorworks 2015