VS:CriteriaVolume

From Vectorworks Developer
Revision as of 14:26, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

DEPRECATED after Vectorworks2012. See VolumeN for a replacement.

Returns the volume of the items matching the specified criteria. If more than one object matches the search criteria, the sum of all the volumes of the matching objects will be returned.

CriteriaVolume will return only return volumes on objects which support the solids modelling functions.

FUNCTION CriteriaVolume(
c :CRITERIA) : REAL;
def vs.CriteriaVolume(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Remarks

This function returns the volume of the items matching the current criteria. It will return 0 for any objects that will not work with the solids modeling functions.

Example

VectorScript

totalVol:=CriteriaVolume((C='Empty Space'));

Python


Version

Availability: from VectorWorks12.0

Deprecated: Vectorworks 2012