VS:CriteriaVolume: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(add python example)
 
Line 41: Line 41:
==== VectorScript ====
==== VectorScript ====
<code lang="pas">
<code lang="pas">
totalVol:=CriteriaVolume((C='Empty Space'));</code>
totalVol := CriteriaVolume((C = 'Empty Space'));</code>
 
==== Python ====
==== Python ====
<code lang="py">
<code lang="py">
 
totalVol = vs.CriteriaVolume(("C = 'Empty Space'"))
</code>
</code>
</sample>
</sample>

Latest revision as of 18:24, 15 May 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

DEPRECATED after Vectorworks2012. See VolumeN for a replacement.

Returns the volume of the items matching the specified criteria. If more than one object matches the search criteria, the sum of all the volumes of the matching objects will be returned.

CriteriaVolume will return only return volumes on objects which support the solids modelling functions.

FUNCTION CriteriaVolume(
c :CRITERIA) : REAL;
def vs.CriteriaVolume(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Remarks

This function returns the volume of the items matching the current criteria. It will return 0 for any objects that will not work with the solids modeling functions.

Example

VectorScript

totalVol := CriteriaVolume((C = 'Empty Space'));

Python

totalVol = vs.CriteriaVolume(("C = 'Empty Space'"))

Version

Availability: from VectorWorks12.0

Deprecated: Vectorworks 2012