VS:CriteriaSurfaceArea

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

DEPRECATED after Vectorworks2012.. See SurfaceAreaN for a replacement.

Returns the surface area of the items matching the specified criteria. If more than one object matches the search criteria, the sum of all the surface areas of the matching objects will be returned.

CriteriaSurfaceArea will return only return areas on objects which support the solids modelling functions.

FUNCTION CriteriaSurfaceArea(
c :CRITERIA) : REAL;
def vs.CriteriaSurfaceArea(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Remarks

This function returns the surface area of the items matching the current criteria. It will return 0 for any objects that will not work with the solids modeling functions.

Example

VectorScript

totalArea:=CriteriaSurfaceArea((C='Empty Space'));

Python


Version

Availability: from VectorWorks12.0

Deprecated: Vectorworks 2012