VS:CriteriaArea

From Vectorworks Developer
Revision as of 20:00, 20 September 2011 by Root (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

DEPRECATED after Vectorworks2012. See AreaN for a replacement.

Returns the area of an object. If more than one object matches the search criteria, the function will return the sum of all the matching object areas.

FUNCTION CriteriaArea(
c :CRITERIA) : REAL;
def vs.CriteriaArea(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Example

VectorScript

totalA:=Area((C='Plywood')and(L='First'));
{returns the area of all objects in class 'Plywood' on layer 'First'}

Python


Version

Availability: from VectorWorks12.0

Deprecated: Vectorworks 2012