VS:CriteriaArea: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 14:26, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

DEPRECATED after Vectorworks2012. See AreaN for a replacement.

Returns the area of an object. If more than one object matches the search criteria, the function will return the sum of all the matching object areas.

FUNCTION CriteriaArea(
c :CRITERIA) : REAL;
def vs.CriteriaArea(c):
    return REAL

Parameters

c CRITERIA Search criteria.

Example

VectorScript

totalA:=Area((C='Plywood')and(L='First'));
{returns the area of all objects in class 'Plywood' on layer 'First'}

Python


Version

Availability: from VectorWorks12.0

Deprecated: Vectorworks 2012