VS:CreateWSImage: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(this shifts other images if the worksheet already has an image somewhere else.)
Line 33: Line 33:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<remark>
([[User:Orso.b.schmid|Orso]], 2015.06.20): It is possible to have any number of worksheet images on drawing, each on a different location. If you use this routine and you already have some images of the chosen worksheet on drawing, the routine will shift the last in the stacking order, placing it at the chosen coordinates. Very tricky.
You must check for the presence of other worksheet images before trying to create a new one.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks9.0
Availability: from VectorWorks 9.0


</version>
</version>

Revision as of 07:18, 20 June 2015

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates an in-document image of the specified worksheet. The specified point location is the top left corner of the image object.

FUNCTION CreateWSImage(
worksheet :HANDLE;
locationX,locationY :REAL) : HANDLE;
def vs.CreateWSImage(worksheet, location):
    return HANDLE

Parameters

worksheet HANDLE Handle to worksheet.
location REAL X-Y coordinate location of image object.

Remarks

(Orso, 2015.06.20): It is possible to have any number of worksheet images on drawing, each on a different location. If you use this routine and you already have some images of the chosen worksheet on drawing, the routine will shift the last in the stacking order, placing it at the chosen coordinates. Very tricky.

You must check for the presence of other worksheet images before trying to create a new one.

Version

Availability: from VectorWorks 9.0