VS:CreateTaperedExtrd2

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new tapered extrude object in the document. This function returns a "general solid" object while the other function, VS:CreateTaperedExtrude, produces a bunch of NURBS surfaces.

FUNCTION CreateTaperedExtrd2(
profileH :HANDLE;
angle :REAL;
height :REAL) : HANDLE;
def vs.CreateTaperedExtrd2(profileH, angle, height):
    return HANDLE

Parameters

profileH HANDLE Handle to object defining profile geometry.
angle REAL Taper angle of extrude (in degrees).
height REAL Height of extrude.

Return Value

Returns a HANDLE to the new tapered extrude if successful, otherwise returns NIL.

Version

Availability: from Vectorworks 2016