VS:CreateTaperedExtrd2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
m (wikify)
 
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Creates a new tapered extrude object in the document. This function returns a &quot;general solid&quot; object while the other function, CreateTaperedExtrude, produces a bunch of NURBS surfaces.</desc>
Creates a new tapered extrude object in the document. This function returns a "general solid" object while the other function, [[VS:CreateTaperedExtrude]], produces a bunch of NURBS surfaces.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 07:26, 10 February 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new tapered extrude object in the document. This function returns a "general solid" object while the other function, VS:CreateTaperedExtrude, produces a bunch of NURBS surfaces.

FUNCTION CreateTaperedExtrd2(
profileH :HANDLE;
angle :REAL;
height :REAL) : HANDLE;
def vs.CreateTaperedExtrd2(profileH, angle, height):
    return HANDLE

Parameters

profileH HANDLE Handle to object defining profile geometry.
angle REAL Taper angle of extrude (in degrees).
height REAL Height of extrude.

Return Value

Returns a HANDLE to the new tapered extrude if successful, otherwise returns NIL.

Version

Availability: from Vectorworks 2016