VS:CreateStoryLayerTemplate

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a Story Layer Template in the current file. Sets the index parameter to the index of the new template in the list of templates. Story Layer Templates are used to define what Layers are typically found in a Story. When a Story is created, the user has the option to automatically create the Layers defined by the Story Layer Templates.

FUNCTION CreateStoryLayerTemplate(
name :STRING;
scaleFactor :REAL;
layerLevelType :STRING;
elevationOffset :REAL;
defaultWallHeight :REAL;
VAR index :INTEGER) : BOOLEAN;
def vs.CreateStoryLayerTemplate(name, scaleFactor, layerLevelType, elevationOffset, defaultWallHeight):
    return (BOOLEAN, index)

Parameters

name STRING The name of the Story Layer Template.
scaleFactor REAL The scale to be assinged to any Layers created from this template.
layerLevelType STRING The Layer Level Type to be assigned to any Layers created from this template.
elevationOffset REAL The offset of the elevation of any Layer created from this template from the elevation of its Story.
defaultWallHeight REAL The wall height to be assigned to any Layer created from this template.
index INTEGER The index of the new template in the list of templates.

Return Value

Whether a Story Layer Template is successfully created.

Example

VAR

success:BOOLEAN;

BEGIN

success := CreateStoryLayerTemplate('Mod-Slab', 1, 'LT_Slab', 0, 6);

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetNumStoryLayerTemplates | VS:GetStoryLayerTemplateName | VS:DeleteStoryLayerTemplate

VS Functions:

[[VS:GetNumStoryLayerTemplates]] | [[VS:GetStoryLayerTemplateName]]

| [[VS:DeleteStoryLayerTemplate]]