VS:CreateStory: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
(No difference)

Revision as of 14:25, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a Story. Stories are used to group layers and are shown on the Story pane of the Organization dialog.

FUNCTION CreateStory(
name :STRING;
suffix :STRING) : BOOLEAN;
def vs.CreateStory(name, suffix):
    return BOOLEAN

Parameters

name STRING The name of the Story to create.
suffix STRING The suffix to be used at the end of the name of a Layer assoiciated with the Story.

Return Value

Whether the Story was successfully created.

Example

VAR

success:BOOLEAN

BEGIN

success := CreateStory('4th Floor', '4');

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetNumStories | VS:GetStoryOfLayer | VS:AssociateLayerWithStory

VS Functions:

[[VS:GetNumStories]] | [[VS:GetStoryOfLayer]]

| [[VS:AssociateLayerWithStory]]