VS:CreateStaticText/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

編集不可能なフィールドを作成します。

文字列の長さで自動的に幅を変更するには、幅のパラメータを-1にします。

PROCEDURE CreateStaticText(
dialogID :LONGINT;
itemID :LONGINT;
text :STRING;
widthInCharacters :LONGINT);
def vs.CreateStaticText(dialogID, itemID, text, widthInCharacters):
    return None

Parameters

dialogID LONGINT ダイアログ番号
itemID LONGINT アイテム番号
text STRING 文字列
widthInCharacters LONGINT 幅(文字数指定)

Example

PROCEDURE Example;
VAR
   dialog1 :INTEGER;
   result  :INTEGER;
PROCEDURE Dialog_Handler(VAR item :LONGINT; data :LONGINT);
BEGIN
END;
BEGIN
   dialog1 := CreateLayout('Example Dialog', FALSE, 'OK', 'Cancel');
   CreateEditText(dialog1, 4, 'default text', 16);
   CreateStaticText(dialog1, 5, 'default text', 16);
   SetFirstLayoutItem(dialog1, 4);
   SetBelowItem(dialog1, 4, 5, 0, 0);
   result := RunLayoutDialog(dialog1, Dialog_Handler);
END;
RUN(Example);

Version

利用可能バージョン: VectorWorks9.0

See Also

関連関数:

VS:CreateStyledStatic

関連関数: [[VS:CreateStyledStatic]]