VS:CreateStaticHatchFromObject

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a static hatch using inHatchName inside the bounds of the inObj. The pX , pY and rotationAngle arguments determine the hatch origin and rotation used to generate the result.

FUNCTION CreateStaticHatchFromObject(
inObj :HANDLE;
inHatchName :STRING;
pX,pY :REAL;
rotationAngle :REAL) : HANDLE;
def vs.CreateStaticHatchFromObject(inObj, inHatchName, p, rotationAngle):
    return HANDLE

Parameters

inObj HANDLE An object used as the boundary for the output.
inHatchName STRING The name of the hatch definition
p REAL A point specifying the origin of the output
rotationAngle REAL An angle specifying an offset angle to use to create the output

Return Value

A group of lines in a hatch pattern as specified.

Example

VectorScript

PROCEDURE Example;
VAR
h:HANDLE;
x,y:REAL;
BEGIN
GetPt(x,y);
h := CreateStaticHatchFromObject(FSActLayer,'Default Hatch', x, y, 0);
DSelectAll;
SetSelect(h);
END;
RUN(Example);

Python

def PickPointCallback(pt):
	h = vs.CreateStaticHatchFromObject(vs.FSActLayer(),'Default Hatch', pt[0], pt[1], 0)
vs.GetPt( PickPointCallback )

Version

Availability: from VectorWorks10.5