VS:CreateStandardIconControl/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

アプリケーションアイコンや警告アイコンで表示される標準アイコンアイテム作成します。

アイコン番号(0:VectorWorksアプリケーションアイコン/1:インフォメーションアイコン/2:ストップアイコン/3:警告アイコン/4:クエスチョンマークアイコン)

PROCEDURE CreateStandardIconControl(
dialogID :LONGINT;
iconControlID :LONGINT;
iconNumber :INTEGER);
def vs.CreateStandardIconControl(dialogID, iconControlID, iconNumber):
    return None

Parameters

dialogID LONGINT ダイアログ番号
iconControlID LONGINT アイコンアイテム番号
iconNumber INTEGER アイコン番号

Example

dlog := CreateLayout('Untitled Dialog', False, 'OK', 'Cancel');

	CreateStandardIconControl(dlog, 4, 0);
	SetFirstLayoutItem(dlog, 4);

	result := RunLayoutDialog(dlog, EventHandler);

Version

利用可能バージョン: VectorWorks11.5