VS:CreateRoof/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:25, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

新しい屋根を作成し、そのハンドルを返します。

FUNCTION CreateRoof(
genGableWall :BOOLEAN;
bearingInsetDistance :REAL)Coordinate); roofThickDistance:REAL (Coordinate); miterType:INTEGER; vertMiterDistance:REAL (Coordinate)) : HANDLE;
def vs.CreateRoof(genGableWall, bearingInsetDistance, roofThickDistance, miterType, vertMiterDistance):
    return HANDLE

Parameters

genGableWall BOOLEAN 切り妻の有無
bearingInsetDistance REAL (Coordinate) 壁からの距離
roofThickDistance REAL (Coordinate) 屋根の厚み
miterType INTEGER 切り妻の種類
vertMiterDistance REAL (Coordinate) 切り妻の高さ

Example

roofHandle := CreateRoof(TRUE,5 1/2",5 1/2",4,0");
AppendRoofEdge(roofHandle, -87'4",-38'4",#45d 0' 0" ,2'0",10'0");
AppendRoofEdge(roofHandle, -30'2",-38'4",#45d 0' 0" ,2'0",10'0");
AppendRoofEdge(roofHandle, -30'2",45'10",#45d 0' 0" ,2'0",10'0");
AppendRoofEdge(roofHandle, -87'4",45'10",#45d 0' 0" ,2'0",10'0");

Version

利用可能バージョン: VectorWorks8.0

See Also

関連関数:

VS:AppendRoofEdge

関連関数: [[VS:AppendRoofEdge]]