VS:CreateResourcePopup

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a text popup similar to a pulldown menu that opens a Resource Manager window.


This is basically the same as the Thumbnail popup but the control only displays the name of the selected item (it does not display its thumbnail), resembling a pulldown menu control.

PROCEDURE CreateResourcePopup(
nDialogID :LONGINT;
nComponentID :LONGINT;
nWidthInChars :INTEGER);
def vs.CreateResourcePopup(nDialogID, nComponentID, nWidthInChars):
    return None

Parameters

nDialogID LONGINT The index of the dialog layout containing the control.
nComponentID LONGINT The index that will identify the control item.
nWidthInChars INTEGER The width of the displayed text in standard character count. See GetDlgCtrlWidthStdCh.

Version

Availability: from Vectorworks 2021