VS:CreateResizableLayout/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

リサイズ可能なダイアログのレイアウトを作成します。


リサイズすると、ResizeDialogCイベントが起こります。

FUNCTION CreateResizableLayout(
dialogTitle :STRING;
hasHelp :BOOLEAN;
defaultButtonName :STRING;
cancelButtonName :STRING;
widthResizable :BOOLEAN;
heightResizable :BOOLEAN) : LONGINT;
def vs.CreateResizableLayout(dialogTitle, hasHelp, defaultButtonName, cancelButtonName, widthResizable, heightResizable):
    return LONGINT

Parameters

dialogTitle STRING ダイアログのタイトル
hasHelp BOOLEAN ヘルプウインドウの設定(TRUE:表示/FALSE:非表示)
defaultButtonName STRING デフォルトボタンの文字列
cancelButtonName STRING キャンセルボタンの文字列
widthResizable BOOLEAN 幅変更の設定(TRUE:オン/FALSE:オフ)
heightResizable BOOLEAN 高さ変更の設定(TRUE:オン/FALSE:オフ)

Return Value

新しく作成されたレイアウトのダイアログ番号を返します。

Version

利用可能バージョン: VectorWorks12.0

See Also

関連関数:

VS:SetEdgeBinding | VS:SetProportionalBinding

関連関数:

[[VS:SetEdgeBinding]]

| [[VS:SetProportionalBinding]]