VS:CreateResizableLayout

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a new resizable Layout Manager dialog.

Resizable dialogs raise the ResizeDialogC event when resized.

FUNCTION CreateResizableLayout(
dialogTitle :STRING;
hasHelp :BOOLEAN;
defaultButtonName :STRING;
cancelButtonName :STRING;
widthResizable :BOOLEAN;
heightResizable :BOOLEAN) : LONGINT;
def vs.CreateResizableLayout(dialogTitle, hasHelp, defaultButtonName, cancelButtonName, widthResizable, heightResizable):
    return LONGINT

Parameters

dialogTitle STRING
hasHelp BOOLEAN
defaultButtonName STRING
cancelButtonName STRING
widthResizable BOOLEAN
heightResizable BOOLEAN

Remarks

The parameters are the same as CreateLayout, except for widthResizable and heightResizable, which specify that the width and height, respectively, be resizable. A dialog ID is returned by the function.

Version

Availability: from VectorWorks12.0

See Also

VS Functions:

VS:SetEdgeBinding | VS:SetProportionalBinding

VS Functions:

[[VS:SetEdgeBinding]]

| [[VS:SetProportionalBinding]]