VS:CreateOffsetNurbsObjectHandle/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

ハンドルで指定したNURBS図形オフセットしてNURBS図形を新規に作成し、そのハンドルを返します。

FUNCTION CreateOffsetNurbsObjectHandle(
h :HANDLE;
offsetDistance :REAL)Coordinate)) : HANDLE;
def vs.CreateOffsetNurbsObjectHandle(h, offsetDistance):
    return HANDLE

Parameters

h HANDLE NURBS図形のハンドル
offsetDistance REAL (Coordinate) オフセット値

Example

PROCEDURE Example;
VAR
	h :handle;
BEGIN
	CallTool(-204);
	h := FSActLayer;
	h := ConvertToNURBS(h, false);
	h := CreateOffsetNurbsObjectHandle(h, 1);
END;
RUN(Example);

Version

利用可能バージョン: VectorWorks10.0