VS:CreateOffsetNurbsObjectHandle

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns a handle to a NURBS object that is offset from the given NURBS object h by the offset distance.

FUNCTION CreateOffsetNurbsObjectHandle(
h :HANDLE;
offsetDistance :REAL) : HANDLE;
def vs.CreateOffsetNurbsObjectHandle(h, offsetDistance):
    return HANDLE

Parameters

h HANDLE Handle to object.
offsetDistance REAL Offset distance. Positive offsets outwards.

Example

VectorScript

PROCEDURE Example;
VAR
h :handle;
BEGIN
CallTool(-204);
h := FSActLayer;
h := ConvertToNURBS(h, false);
h := CreateOffsetNurbsObjectHandle(h, 1);
END;
RUN(Example);

Python


Version

Availability: from VectorWorks10.0