VS:CreateMarkerPopup: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:25, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a popup control that displays the various marker styles available in VectorWorks and allows the user to choose one. Markers are the adornments at the endpoints of line objects and consist of styles like arrow, circle, cross, etc.

PROCEDURE CreateMarkerPopup(
dialogID :LONGINT;
componentID :LONGINT);
def vs.CreateMarkerPopup(dialogID, componentID):
    return None

Parameters

dialogID LONGINT Id of the dialog
componentID LONGINT Id of the popup control

Example

VectorScript

PROCEDURE Example;
VAR
dialog1	:INTEGER;
result	:INTEGER;

PROCEDURE Dialog_Handler(VAR item :LONGINT; data :LONGINT);
BEGIN
END;

BEGIN
dialog1 := CreateLayout('Untitled Dialog', FALSE, 'OK', 'Cancel');
CreateMarkerPopup(dialog1, 4);
SetFirstLayoutItem(dialog1,  4);
result := RunLayoutDialog(dialog1, Dialog_Handler);
END;
RUN(Example);

Python

def Dialog_Handler( item , data ):
	pass

def Example():
	dialog1 = vs.CreateLayout('Untitled Dialog', False, 'OK', 'Cancel')
	vs.CreateMarkerPopup(dialog1, 4)
	vs.SetFirstLayoutItem(dialog1,  4)
	result = vs.RunLayoutDialog(dialog1, Dialog_Handler)

Example()

Version

Availability: from VectorWorks10.5