VS:CreateInterpolatedSurface

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates an interpolated surface with the specified degrees and number of points. The resulting surface passes through each of the interpoliation points. If a handle to a NURBS surface is provided, the interpolated surface will approximate that surface. If the handle is NULL, it creates a rectangular surface.

FUNCTION CreateInterpolatedSurface(
surfaceHandle :HANDLE;
numUPts :LONGINT;
numVPts :LONGINT;
uDegree :INTEGER;
vDegree :INTEGER) : HANDLE;
def vs.CreateInterpolatedSurface(surfaceHandle, numUPts, numVPts, uDegree, vDegree):
    return HANDLE

Parameters

surfaceHandle HANDLE Handle to a NURBS surface to approximate
numUPts LONGINT Number of interpolation points in the U parametric direction. Must be greater than uDegree.
numVPts LONGINT Number of interpolation points in the V parametric direction. Must be greater than vDegree.
uDegree INTEGER Degree of the surface in the u parametric direction
vDegree INTEGER Degree of the surface in the v parametric direction

Return Value

Handle to the new interpolated surface object.

Version

Availability: from VectorWorks10.0