VS:CreateImgFromSymbol: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 19:25, 12 September 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

FUNCTION CreateImgFromSymbol(
symbolName :STRING;
symbolHeight :INTEGER;
symbolWidth :INTEGER;
symbolMargin :INTEGER;
renderMode :INTEGER;
view :INTEGER) : HANDLE;
def vs.CreateImgFromSymbol(symbolName, symbolHeight, symbolWidth, symbolMargin, renderMode, view):
    return HANDLE

Parameters

symbolName STRING The name of the symbol to display.
symbolHeight INTEGER The height of the symbol to display.
symbolWidth INTEGER The width of the symbol to display.
symbolMargin INTEGER The margin of the symbol to display.
renderMode INTEGER The render mode in which to display the symbol.
view INTEGER The standard view in which to display the symbol.

Return Value

Returns the handle to the newly create image resource if successful; nil otherwise.

Version

Availability: from Vectorworks 2018