VS:CreateImagePushButton

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates an image push button. Replaces CreateIconPushButton

PROCEDURE CreateImagePushButton(
dialogID :LONGINT;
controlID :LONGINT;
widthInCharacters :INTEGER;
imageSpecifier :DYNARRAY[] of CHAR);
def vs.CreateImagePushButton(dialogID, controlID, widthInCharacters, imageSpecifier):
    return None

Parameters

dialogID LONGINT The dialog identifier given by the command to create the dialog.
controlID LONGINT The identifier that should be assigned to the control.
widthInCharacters INTEGER The width of the control.
imageSpecifier DYNARRAY[] of CHAR The string identifier for the image. It should be of the form "ResourceFileNameWithoutExtension/PathOfImageFile".

Version

Availability: from Vectorworks 2012