VS:CreateIconPushButton/ja

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

アイコンプッシュボタンを作成し、アイコンの番号と幅(文字数)を指定します。廃止予定の関数です。代わりに CreateImagePushButton を使用してください。

PROCEDURE CreateIconPushButton(
nDialogID :LONGINT;
nComponentID :LONGINT;
nIconID :INTEGER;
nWidthInChars :INTEGER);
def vs.CreateIconPushButton(nDialogID, nComponentID, nIconID, nWidthInChars):
    return None

Parameters

nDialogID LONGINT
nComponentID LONGINT
nIconID INTEGER the index of the ICN# resource in the currently open rsrc file (or qtr on Windows)
nWidthInChars INTEGER

Example

PROCEDURE Example;
VAR
   dialog1 :INTEGER;
   result  :INTEGER;
   boo     :BOOLEAN;
 
PROCEDURE Dialog_Handler(VAR item :LONGINT; data :LONGINT);
BEGIN
END;
 
BEGIN
   boo := SetVSResourceFile('IP Resources');
   dialog1 := CreateLayout('Example Dialog', FALSE, 'OK', 'Cancel');
   CreateIconPushButton(dialog1, 4, 11021, 20);
   SetFirstLayoutItem(dialog1, 4);
   result := RunLayoutDialog(dialog1, Dialog_Handler);
END;
RUN(Example);

Version

CreateIconPushButton 廃止バージョン: Vectorworks 2012


利用可能バージョン: VectorWorks12.5