VS:CreateEditReal/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(added field type table)
 
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
実数型の編集フィールドを作成します。</desc>
実数型の編集フィールドを作成します。


{| class="wikitable"
|+ 表 - EditReal フィールドの種類
! 番号 !! フィールド値
|-
| 1
| REAL 値
|-
| 2
| 角度 値
|-
| 3
| 寸法
|-
| 4
| X 座標
|-
| 5
| Y 座標
|}
</desc>
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>

Latest revision as of 01:44, 29 April 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

実数型の編集フィールドを作成します。

表 - EditReal フィールドの種類
番号 フィールド値
1 REAL 値
2 角度 値
3 寸法
4 X 座標
5 Y 座標
PROCEDURE CreateEditReal(
dialogID :LONGINT;
itemID :LONGINT;
editRealType :LONGINT;
defaultValue :REAL;
widthInCharacters :LONGINT);
def vs.CreateEditReal(dialogID, itemID, editRealType, defaultValue, widthInCharacters):
    return None

Parameters

dialogID LONGINT ダイアログ番号
itemID LONGINT アイテム番号
editRealType LONGINT 数値タイプ
defaultValue REAL 初期値
widthInCharacters LONGINT 幅(文字数指定)

Example

PROCEDURE Example;
VAR
	dialog1 :INTEGER;
	result  :INTEGER;
PROCEDURE Dialog_Handler(VAR item :LONGINT; data :LONGINT);
BEGIN
END;
BEGIN
	dialog1 := CreateLayout('Example Dialog', FALSE, 'OK', 'Cancel');
	CreateEditReal(dialog1, 4, 3, 123, 16);
	SetFirstLayoutItem(dialog1, 4);
	result := RunLayoutDialog(dialog1, Dialog_Handler);
END;
RUN(Example);

Version

利用可能バージョン: VectorWorks9.0