VS:CreateEditInteger/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

整数型の編集フィールドを作成します。

PROCEDURE CreateEditInteger(
dialogID :LONGINT;
itemID :LONGINT;
defaultValue :LONGINT;
widthInCharacters :LONGINT);
def vs.CreateEditInteger(dialogID, itemID, defaultValue, widthInCharacters):
    return None

Parameters

dialogID LONGINT ダイアログ番号
itemID LONGINT アイテム番号
defaultValue LONGINT 初期値
widthInCharacters LONGINT 幅(文字数指定)

Example

PROCEDURE Example;
VAR
	dialog1 :INTEGER;
	result  :INTEGER;
PROCEDURE Dialog_Handler(VAR item :LONGINT; data :LONGINT);
BEGIN
END;
BEGIN
	dialog1 := CreateLayout('Example Dialog', FALSE, 'OK', 'Cancel');
	CreateEditInteger(dialog1, 4, 123, 16);
	SetFirstLayoutItem(dialog1, 4);
	result := RunLayoutDialog(dialog1, Dialog_Handler);
END;
RUN(Example);

Version

利用可能バージョン: VectorWorks9.0