VS:CreateDuplicateObjN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (fix typo)
m (Fix Typo)
 
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Duplicates the specified object and inserts the new  object into the container.  If container is nil, the new object will be inserted in the active container (Functionality of CreateDuplicateObject). This functions add an extra input paramer to maintain height relative to the specified layer.</desc>
Duplicates the specified object and inserts the new  object into the container.  If container is nil, the new object will be inserted in the active container (Functionality of CreateDuplicateObject). This functions add an extra input parameter to maintain height relative to the specified layer.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 05:41, 8 May 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Duplicates the specified object and inserts the new object into the container. If container is nil, the new object will be inserted in the active container (Functionality of CreateDuplicateObject). This functions add an extra input parameter to maintain height relative to the specified layer.

FUNCTION CreateDuplicateObjN(
objectToDuplicate :HANDLE;
containerHandle :HANDLE;
maintainHeightRelativeToLayer :BOOLEAN) : HANDLE;
def vs.CreateDuplicateObjN(objectToDuplicate, containerHandle, maintainHeightRelativeToLayer):
    return HANDLE

Parameters

objectToDuplicate HANDLE
containerHandle HANDLE
maintainHeightRelativeToLayer BOOLEAN

Version

Availability: from Vectorworks 2020