VS:CreateCustomObjectN/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

位置と角度を指定してプラグインオブジェクトを作成し、そのハンドルを返します。また、設定ダイアログの表示/非表示を設定できます。

FUNCTION CreateCustomObjectN(
objectName :STRING;
p :REAL;
rotationAngle :REAL;
showPref :BOOLEAN) : HANDLE;
def vs.CreateCustomObjectN(objectName, p, rotationAngle, showPref):
    return HANDLE

Parameters

objectName STRING プラグインオブジェクトの名前
p REAL 配置する座標
rotationAngle REAL 回転角度(度)
showPref BOOLEAN 設定ダイアログの設定(TRUE:表示/FALSE:非表示)

Example

PROCEDURE Example;
VAR
   h :HANDLE;
BEGIN
   h := CreateCustomObjectN('Door', 0, 0, 0, False);
END;
RUN(Example);

Version

利用可能バージョン: VectorWorks10.0