VS:CreateCustomObject

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a custom object instance at the specified location and angle of rotation. For the objectName, use the "internal" plug-in name (the one assigned in the plug-in editor), as opposed to the filename (which can be different).

FUNCTION CreateCustomObject(
objectName :STRING;
pX,pY :REAL;
rotationAngle :REAL) : HANDLE;
def vs.CreateCustomObject(objectName, p, rotationAngle):
    return HANDLE

Parameters

objectName STRING Name of object.
p REAL Insertion point of object instance.
rotationAngle REAL Rotation angle (in degrees) of object instance.

Return Value

Returns a HANDLE to the new object.

Remarks

Like for objects created through CreateCustomObjectPath, they don't resolve as "new objects" after creation with this routine.

Version

Availability: from VectorWorks8.5

See Also

VS Functions:

VS:CreateCustomObjectPath

VS Functions: [[VS:CreateCustomObjectPath]]