VS:CreateCustomControl: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (fixed typo)
 
(One intermediate revision by one other user not shown)
Line 6: Line 6:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Creates a layout manager control in a VectorScript to be used in conjuction with GS_OverrideControl in an external dialog handler.</desc>
Creates a layout manager control in a VectorScript to be used in conjunction with GS_OverrideControl in an external dialog handler.</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 47: Line 47:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from VectorWorks13.0
Availability: from VectorWorks 13.0


</version>
</version>

Latest revision as of 04:13, 17 May 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a layout manager control in a VectorScript to be used in conjunction with GS_OverrideControl in an external dialog handler.

PROCEDURE CreateCustomControl(
dialogID :LONGINT;
componentID :LONGINT;
iWidth :INTEGER;
iHeight :INTEGER);
def vs.CreateCustomControl(dialogID, componentID, iWidth, iHeight):
    return None

Parameters

dialogID LONGINT
componentID LONGINT
iWidth INTEGER
iHeight INTEGER

Version

Availability: from VectorWorks 13.0