VS:CreateCustThumbPopup

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Creates a custom thumbnail popup that can be populated with previews of objects in Vectorworks.

PROCEDURE CreateCustThumbPopup(
dialogID :LONGINT;
controlID :LONGINT;
sizeType :INTEGER);
def vs.CreateCustThumbPopup(dialogID, controlID, sizeType):
    return None

Parameters

dialogID LONGINT The dialog identifier given by the command to create the dialog.
controlID LONGINT The identifier that should be assigned to the control.
sizeType INTEGER The size type of the control

Remarks

There are two thumbnail sizes at the moment, 64x64 and 128x32.

  • sizeType = 0
    • The default size (64x64) used for most of the resource types.
  • sizeType = 1
    • The LineType size (128x32) used for displaying Line Types..

Version

Availability: from Vectorworks 2013