VS:Count

From Vectorworks Developer
Revision as of 14:25, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Counts all of the objects which match the search criteria.

FUNCTION Count(
c :CRITERIA) : LONGINT;
def vs.Count(c):
    return LONGINT

Parameters

c CRITERIA Search criteria.

Remarks

Undocumented is that criteria also accept the object type flag as parameter. The example above can also be written:

CountValue := Count((FP=4)and(T=3)); { 3 is object type flag for 'Rectangle&amp' }

This is valid for all object types being assigned a name in the VectorScript Appendix.

Example

VectorScript

CountValue := Count((FP=4)and(T='Rect'));
{counts all rectangles with a fillpat index of 4}

Python


Version

Availability: from All Versions