VS:Copy

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function Copy returns a substring from a specified source string.

FUNCTION Copy(
source :DYNARRAY[] of CHAR;
index :INTEGER;
count :INTEGER) : DYNARRAY[] of CHAR;
def vs.Copy(source, index, count):
    return DYNARRAY[] of CHAR

Parameters

source DYNARRAY[] of CHAR Source string.
index INTEGER Start position in text string.
count INTEGER Length of substring.

Example

VectorScript

Message(Copy('A sample string',10,6))
{returns 'string'}

Python

vs.Message(vs.Copy('A sample string',10,6))

Version

Availability: from All Versions