VS:ConvertToPolyline

From Vectorworks Developer
Revision as of 17:11, 13 August 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Converts objects to polygons or polylines. Currently supported object types: line, rectangle, oval, polygon, arc, rounded rectangle, and polyline. If the object cannot be converted, the original object is not deleted, and the return handle is nil.

FUNCTION ConvertToPolyline(
h :HANDLE) :HANDLE;
def vs.ConvertToPolyline(h):
    return HANDLE

Parameters

h HANDLE

Example

PROCEDURE Example;
BEGIN
   CallTool(-203);
   Message(GetVertNum(ConvertToPolyline(FSActLayer)));
END;
RUN(Example);

Version

Availability: from All Versions

This is drop-in function.