VS:ConvertToPolyline: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(2 intermediate revisions by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Converts objects to polygons or polylines. Currently supported object types: line, rectangle, oval, polygon, arc, rounded rectangle, and polyline. If the object cannot be converted, the original object is not deleted, and the return handle is nil.
Converts any enclosed shape (circle, rectangle, ellipse, etc.) into a polygon or polyline. Does not polygonalize.</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION ConvertToPolyline(h :HANDLE) :HANDLE;
FUNCTION ConvertToPolyline(h:HANDLE) : HANDLE;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 29: Line 28:
</lineList>
</lineList>
</params>
</params>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<remark></remark>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<sample></sample>
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<seeAlso></seeAlso>
<code lang="pas">
PROCEDURE Example;
BEGIN
  CallTool(-203);
  Message(GetVertNum(ConvertToPolyline(FSActLayer)));
END;
RUN(Example);</code>
 
</sample>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>


[[Category:VS Function Reference|ConvertToPolyline]]
[[Category:VS Function Reference|ConvertToPolyline]]
[[Category:VS Function Reference:Objects - 2D|ConvertToPolyline]]
[[Category:VS Function Reference:Graphic Calculation|ConvertToPolyline]]

Latest revision as of 17:35, 18 September 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Converts any enclosed shape (circle, rectangle, ellipse, etc.) into a polygon or polyline. Does not polygonalize.

FUNCTION ConvertToPolyline(
h :HANDLE) : HANDLE;
def vs.ConvertToPolyline(h):
    return HANDLE

Parameters

h HANDLE

Version

Availability: from Vectorworks 2014